Tech Blog‎ > ‎

Many packages did not load correctly in Visual Studio 2010

posted Sep 7, 2012, 8:32 AM by Victor Zakharov   [ updated Sep 18, 2012, 9:24 AM ]
So I have my VS 2010 and also just installed VS 2012. After that my main project started showing this error: 

"The ‘VSTS for Database Professionals Sql Server Data-tier Application’ package did not load correctly"

And also some other errors about components I have never heard before.

Here is a solution provided by Eric Lee, which worked for me:
Even though the author intended it for a slightly different set of actions.
Short version (copied from the above website):
  1. Locate your Visual Studio 2010 installation media.
  2. In the \WCU\DAC folder, you’ll find three MSIs: DACFramework_enu.msi, DACProjectSystemSetup_enu.msi, and TSqlLanguageService_enu.msi. Run and install each of them.
  3. Reapply Visual Studio 2010 SP1.
Thanks, Eric!
Comments